Fork me on GitHub

Supported Platforms for Ice 3.3.0

Ice for C++

Platform Compiler
Windows XP SP2 (x86) Visual Studio 2005 SP1
Visual C++ 2005 Express Edition
Visual Studio 2008
Visual C++ 2008 Express Edition
Visual C++ 6.0 SP5 and STLport 4.6.2 or later
CodeGear C++Builder 2007
Windows Vista (x86 and x64) Visual Studio 2005 SP1
Visual C++ 2005 Express Edition (x86 only)
Visual Studio 2008
Visual C++ 2008 Express Edition (x86 only)
CodeGear C++Builder 2007 (x86 only)
Windows Server 2003 Standard (x86 and x64) Visual Studio 2005 SP1
Visual C++ 2005 Express Edition (x86 only)
Visual Studio 2008
Visual C++ 2008 Express Edition (x86 only)
Windows Server 2008 Standard (x86 and x64) Visual Studio 2005 SP1
Visual C++ 2005 Express Edition (x86 only)
Visual Studio 2008
Visual C++ 2008 Express Edition (x86 only)
Red Hat Enterprise Linux 4.6 (i386 and x86_64) GCC 3.4.6
Red Hat Enterprise Linux 5.1 (i386 and x86_64) GCC 4.1.2
SuSE Linux Enterprise Server 10 SP1 (i586 and x86_64) GCC 4.1.2
MacOS X Leopard (Intel x86) GCC 4.0.1
Solaris 10 (SPARC and x86/x64) Sun Studio 12 (CC 5.9), 32/64 bit
HP-UX 11.11 (PA-RISC) HP aCC 3.56, 32/64 bit

Ice for Java

Platform Compiler
All supported platforms except HP-UX JDK 1.5.0 or 1.6.0

Ice for .NET

Platform Compiler
Windows XP SP2 (x86) Visual Studio 2005 (.NET 2.0)
Visual Studio 2008 (.NET 3.5)
Windows Vista (x86 and x64) Visual Studio 2005 (.NET 2.0)
Visual Studio 2008 (.NET 3.5)
Windows Server 2003 Standard (x86 and x64) Visual Studio 2005 (.NET 2.0)
Visual Studio 2008 (.NET 3.5)
Windows Server 2008 Standard (x86 and x64) Visual Studio 2005 (.NET 2.0)
Visual Studio 2008 (.NET 3.5)
SuSE Linux Enterprise Server 10 SP1 (i586 and x86_64) Mono 1.2.2

Ice for PHP

Platform Environment
Windows XP SP2 (x86) PHP 5.2.6
Red Hat Enterprise Linux 4.6 (i386 and x86_64) PHP 5.1.6
Red Hat Enterprise Linux 5.1 (i386 and x86_64) PHP 5.1.6
SuSE Linux Enterprise Server 10 SP1 (i586 and x86_64) PHP 5.1.2

Ice for Python

Platform Environment
All Ice for C++ platforms except HP-UX Python 2.3, 2.4 or 2.5

Ice for Ruby

Platform Environment
Windows XP SP2 (x86) Ruby 1.8.6
Red Hat Enterprise Linux 4.6 (i386 and x86_64) Ruby 1.8.1
Red Hat Enterprise Linux 5.1 (i386 and x86_64) Ruby 1.8.5